package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\w+)[^=;]+)=?\s*([^;]+)`)
var str = `int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString="25";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}