#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:\w+)[^=;]+)=?\s*([^;]+)"
Local $sString = "int i;" & @CRLF & _
"String s;" & @CRLF & _
"public int go = 23; sdfsdfsdfsdf" & @CRLF & _
"public static final int value,valu2;" & @CRLF & _
"public static final String t,t1,t2 = 23;" & @CRLF & _
"String myString="25";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")