const regex = /^((?:\w+)[^=;]+)=?\s*([^;]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\w+)[^=;]+)=?\\s*([^;]+)', 'gm')
const str = `int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString="25";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}