re = /SushiRoles.*:.*\"MMa\"/
str = '<AuthZ><PersonaId:"1090553942"></PersonaId><SushiRoles 123:abc "MMa"></SushiRoles><R:"1090553939">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end