const regex = /SushiRoles.*:.*\"MMa\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SushiRoles.*:.*\\"MMa\\"', '')
const str = `<AuthZ><PersonaId:"1090553942"></PersonaId><SushiRoles 123:abc "MMa"></SushiRoles><R:"1090553939">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}