using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SushiRoles.*:.*\""MMa\""";
string input = @"<AuthZ><PersonaId:""1090553942""></PersonaId><SushiRoles 123:abc ""MMa""></SushiRoles><R:""1090553939"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}