#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SushiRoles.*:.*\"MMa\""
Local $sString = "<AuthZ><PersonaId:"1090553942"></PersonaId><SushiRoles 123:abc "MMa"></SushiRoles><R:"1090553939">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")