$re = '/(?<bank_code>[a-z|A-Z]{4})(?<code_pays>[a-z|A-Z]{4})\d{2}(\d{3})?/m';
$str = 'aaaabb22
aaaabb22333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);