package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<bank_code>[a-z|A-Z]{4})(?<code_pays>[a-z|A-Z]{4})\d{2}(\d{3})?`)
var str = `aaaabb22
aaaabb22333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}