using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<bank_code>[a-z|A-Z]{4})(?<code_pays>[a-z|A-Z]{4})\d{2}(\d{3})?";
string input = @"aaaabb22
aaaabb22333
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}