const regex = /(?<bank_code>[a-z|A-Z]{4})(?<code_pays>[a-z|A-Z]{4})\d{2}(\d{3})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<bank_code>[a-z|A-Z]{4})(?<code_pays>[a-z|A-Z]{4})\\d{2}(\\d{3})?', 'gm')
const str = `aaaabb22
aaaabb22333
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}