const regex = new RegExp('([\\w\\s]){2}([^;;])', 'gm')
const str = `correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154`;
const subst = `sa`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);