import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\s]){2}([^;;])";
final String string = "correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154";
final String subst = "sa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}