re = /\B\.\w+,? ?/
str = 'ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result