const regex = /\B\.\w+,? ?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B\\.\\w+,? ?', 'g')
const str = `ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);