using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B\.\w+,? ?";
string substitution = @"";
string input = @"ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}