#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\B\.\w+,? ?"
Local $sString = "ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)