// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)").unwrap();
let string = "TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80
TRANSPORT::FRTN_ASR9010";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}