#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)"
Local $sString = "TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80" & @CRLF & _
"TRANSPORT::FRTN_ASR9010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")