using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)";
string input = @"TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80
TRANSPORT::FRTN_ASR9010";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}