package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)`)
var str = `TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80
TRANSPORT::FRTN_ASR9010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}