re = /(?:c|C|С|с|\()(?:\s|_)*(?:B|В|в|(?:\|3)|V|v)(?:\s|_)*(?:о|О|O|o|0|(?:\(\)))/
str = 'C_|3_()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end