package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?:c|C|С|с|\()(?:\s|_)*(?:B|В|в|(?:\|3)|V|v)(?:\s|_)*(?:о|О|O|o|0|(?:\(\)))`)
var str = `C_|3_()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}