const regex = /(?:c|C|С|с|\()(?:\s|_)*(?:B|В|в|(?:\|3)|V|v)(?:\s|_)*(?:о|О|O|o|0|(?:\(\)))/gsu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:c|C|С|с|\\()(?:\\s|_)*(?:B|В|в|(?:\\|3)|V|v)(?:\\s|_)*(?:о|О|O|o|0|(?:\\(\\)))', 'gsu')
const str = `C_|3_()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}