using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:c|C|С|с|\()(?:\s|_)*(?:B|В|в|(?:\|3)|V|v)(?:\s|_)*(?:о|О|O|o|0|(?:\(\)))";
string input = @"C_|3_()";
RegexOptions options = RegexOptions.Singleline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}