// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:::f{4,6}:)?(?P<host>\S+) .* \"(GET|POST) [^\"]+\" 403"#).unwrap();
let string = "112.253.6.182 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"
106.37.177.251 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\"
204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\"
204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}