using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:::f{4,6}:)?(?P<host>\S+) .* \""(GET|POST) [^\""]+\"" 403";
string input = @"112.253.6.182 - - [08/Sep/2014:17:42:56 -0400] ""GET / HTTP/1.1"" 403 579 ""baidu"" ""Mozilla/4.0""
106.37.177.251 - - [08/Sep/2014:17:42:56 -0400] ""GET /index.php HTTP/1.1"" 404 576 ""baidu"" ""Mozilla/4.0""
204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] ""GET /index.php HTTP/1.1"" 404 576 ""baidu"" ""Mozilla/4.0""
204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] ""GET / HTTP/1.1"" 403 579 ""baidu"" ""Mozilla/4.0""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}