# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:::f{4,6}:)?(?P<host>\S+) .* \"(GET|POST) [^\"]+\" 403"
test_str = ("112.253.6.182 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"\n"
"106.37.177.251 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
"204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
"204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.