import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:::f{4,6}:)?(?P<host>\\S+) .* \\\"(GET|POST) [^\\\"]+\\\" 403";
final String string = "112.253.6.182 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"\n"
+ "106.37.177.251 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
+ "204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
+ "204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}