re = /((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?/
str = 'xtalent.net
www.xtalent.org
https://xtalent.net
talent.wp.pl
ising.pl
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end