package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?`)
var str = `xtalent.net
www.xtalent.org
https://xtalent.net
talent.wp.pl
ising.pl
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}