const regex = /((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|https|ftp|ftps)\\:\\\/\\\/|www\\.|)[a-zA-Z0-9\\-\\.]+(\\.[a-zA-Z]{2,3}|\\.pl|\\.net|\\.com)(\\\/\\S*)?', 'g')
const str = `xtalent.net
www.xtalent.org
https://xtalent.net
talent.wp.pl
ising.pl
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}