#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?"
Local $sString = "xtalent.net" & @CRLF & _
"" & @CRLF & _
"www.xtalent.org" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://xtalent.net" & @CRLF & _
"" & @CRLF & _
"talent.wp.pl" & @CRLF & _
"" & @CRLF & _
"ising.pl" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")