$re = '/prvs\=[\w\d]+\=/';
$str = 'prvs=0996c920be=shana.devolder@geldof.be';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);