package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`prvs\=[\w\d]+\=`)
var str = `prvs=0996c920be=shana.devolder@geldof.be`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}