using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"prvs\=[\w\d]+\=";
string input = @"prvs=0996c920be=shana.devolder@geldof.be";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}