const regex = /prvs\=[\w\d]+\=/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('prvs\\=[\\w\\d]+\\=', '')
const str = `prvs=0996c920be=shana.devolder@geldof.be`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}