import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xm) (?(DEFINE) (?<byte> 2[0-4]\\d | 25[0-5] | 1\\d\\d | [1-9]?\\d) ) ^ (10 (?:\\.(?&byte)){3} | 172 \\. (?: 1 [6-9] | 2\\d | 3[01] ) (?:\\.(?&byte)){2} | 192 \\. 168 (?:\\.(?&byte)){2} | ) $";
final String string = "10.0.0.0\n"
+ "10.1.2.3\n"
+ "10.255.255.255\n"
+ "172.16.0.0\n"
+ "172.25.1.2.3\n"
+ "172.31.255.255\n"
+ "12.34.56.78\n"
+ "123.456.789.0\n"
+ "192.168.0.555\n"
+ "192.168.0.0\n"
+ "192.168.1.2\n"
+ "192.168.255.255\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}