#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm) (?(DEFINE) (?<byte> 2[0-4]\d | 25[0-5] | 1\d\d | [1-9]?\d) ) ^ (10 (?:\.(?&byte)){3} | 172 \. (?: 1 [6-9] | 2\d | 3[01] ) (?:\.(?&byte)){2} | 192 \. 168 (?:\.(?&byte)){2} | ) $"
Local $sString = "10.0.0.0" & @CRLF & _
"10.1.2.3" & @CRLF & _
"10.255.255.255" & @CRLF & _
"172.16.0.0" & @CRLF & _
"172.25.1.2.3" & @CRLF & _
"172.31.255.255" & @CRLF & _
"12.34.56.78" & @CRLF & _
"123.456.789.0" & @CRLF & _
"192.168.0.555" & @CRLF & _
"192.168.0.0" & @CRLF & _
"192.168.1.2" & @CRLF & _
"192.168.255.255" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")