package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xm) (?(DEFINE) (?<byte> 2[0-4]\d | 25[0-5] | 1\d\d | [1-9]?\d) ) ^ (10 (?:\.(?&byte)){3} | 172 \. (?: 1 [6-9] | 2\d | 3[01] ) (?:\.(?&byte)){2} | 192 \. 168 (?:\.(?&byte)){2} | ) $`)
var str = `10.0.0.0
10.1.2.3
10.255.255.255
172.16.0.0
172.25.1.2.3
172.31.255.255
12.34.56.78
123.456.789.0
192.168.0.555
192.168.0.0
192.168.1.2
192.168.255.255
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}