re = /access_token=([\w\.]+)/
str = '#access_token=1234.1234abc.1234abc4567defg
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end