$re = '/access_token=([\w\.]+)/';
$str = '#access_token=1234.1234abc.1234abc4567defg
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);