using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"access_token=([\w\.]+)";
string input = @"#access_token=1234.1234abc.1234abc4567defg
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}