package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`access_token=([\w\.]+)`)
var str = `#access_token=1234.1234abc.1234abc4567defg
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}