// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?").unwrap();
let string = "Kraus, Fritz R., (1968) 146
Owen, David I., (2013) 1156
Dalley, Stephanie & Yoffee, Norman, (1991) 001
De Graef, (2016) p. 32 no. 9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}