# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?"
test_str = ("Kraus, Fritz R., (1968) 146\n"
" \n"
"Owen, David I., (2013) 1156\n\n"
"Dalley, Stephanie & Yoffee, Norman, (1991) 001\n\n"
"De Graef, (2016) p. 32 no. 9")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.