package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?`)
var str = `Kraus, Fritz R., (1968) 146
Owen, David I., (2013) 1156
Dalley, Stephanie & Yoffee, Norman, (1991) 001
De Graef, (2016) p. 32 no. 9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}