import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Z][a-z]+[,\\s&]*|[A-Z]\\.),?";
final String string = "Kraus, Fritz R., (1968) 146\n"
+ " \n"
+ "Owen, David I., (2013) 1156\n\n"
+ "Dalley, Stephanie & Yoffee, Norman, (1991) 001\n\n"
+ "De Graef, (2016) p. 32 no. 9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}