re = /^#!(\/usr)?\/bin\/(env )?(ba)?sh$/m
str = '#!/bin/sh
#!/bin/bash
#!/usr/bin/env bash
#!/usr/bin/env sh
#!/usr/bin/env python
#!/usr/bin/env python3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end