#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#!(/usr)?/bin/(env )?(ba)?sh$"
Local $sString = "#!/bin/sh" & @CRLF & _
"#!/bin/bash" & @CRLF & _
"#!/usr/bin/env bash" & @CRLF & _
"#!/usr/bin/env sh" & @CRLF & _
"#!/usr/bin/env python" & @CRLF & _
"#!/usr/bin/env python3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")